summaryrefslogtreecommitdiff
path: root/dev-ml/jingoo/jingoo-1.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jingoo/jingoo-1.4.4.ebuild')
-rw-r--r--dev-ml/jingoo/jingoo-1.4.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/jingoo/jingoo-1.4.4.ebuild b/dev-ml/jingoo/jingoo-1.4.4.ebuild
new file mode 100644
index 000000000000..b5e10ddf85a2
--- /dev/null
+++ b/dev-ml/jingoo/jingoo-1.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml template engine almost compatible with Jinja2"
+HOMEPAGE="https://github.com/tategakibunko/jingoo/"
+SRC_URI="https://github.com/tategakibunko/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/menhir:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_deriving:=
+ dev-ml/ppxlib:=
+ dev-ml/re:=
+ dev-ml/uucp:=
+ dev-ml/uutf:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"