summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-base64/ocaml-base64-3.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-base64/ocaml-base64-3.5.0.ebuild')
-rw-r--r--dev-ml/ocaml-base64/ocaml-base64-3.5.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/ocaml-base64/ocaml-base64-3.5.0.ebuild b/dev-ml/ocaml-base64/ocaml-base64-3.5.0.ebuild
new file mode 100644
index 000000000000..abfff50eb629
--- /dev/null
+++ b/dev-ml/ocaml-base64/ocaml-base64-3.5.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="base64"
+inherit dune
+
+DESCRIPTION="Library for radix-64 representation (de)coding"
+HOMEPAGE="https://github.com/mirage/ocaml-base64"
+SRC_URI="https://github.com/mirage/ocaml-base64/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-ml/rresult dev-ml/bos dev-ml/alcotest )"