summaryrefslogtreecommitdiff
path: root/dev-ml/splittable_random/splittable_random-0.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/splittable_random/splittable_random-0.16.0.ebuild')
-rw-r--r--dev-ml/splittable_random/splittable_random-0.16.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/splittable_random/splittable_random-0.16.0.ebuild b/dev-ml/splittable_random/splittable_random-0.16.0.ebuild
new file mode 100644
index 000000000000..4e4c7a4d1db0
--- /dev/null
+++ b/dev-ml/splittable_random/splittable_random-0.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="PRNG that can be split into independent streams"
+HOMEPAGE="https://github.com/janestreet/splittable_random"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/ppx_assert:${SLOT}
+ dev-ml/ppx_bench:${SLOT}
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_inline_test:${SLOT}
+ dev-ml/ppx_sexp_message:${SLOT}
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppxlib:=
+"
+DEPEND="${RDEPEND}"