summaryrefslogtreecommitdiff
path: root/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r1.ebuild')
-rw-r--r--dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r1.ebuild b/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r1.ebuild
new file mode 100644
index 000000000000..a11f7fb7efc4
--- /dev/null
+++ b/dev-perl/Cache-Simple-TimedExpiry/Cache-Simple-TimedExpiry-0.270.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=JESSE
+MODULE_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="A lightweight cache with timed expiration"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
+IUSE=""
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}