summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime-HiRes
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DateTime-HiRes')
-rw-r--r--dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild19
-rw-r--r--dev-perl/DateTime-HiRes/Manifest4
-rw-r--r--dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch39
-rw-r--r--dev-perl/DateTime-HiRes/metadata.xml12
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild b/dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..8663f56e040a
--- /dev/null
+++ b/dev-perl/DateTime-HiRes/DateTime-HiRes-0.10.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=JHOBLITT
+DIST_VERSION=0.01
+inherit perl-module
+
+DESCRIPTION="Create DateTime objects with sub-second current time resolution"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/DateTime"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+PATCHES=("${FILESDIR}/${P}-datetimelocale.patch" )
diff --git a/dev-perl/DateTime-HiRes/Manifest b/dev-perl/DateTime-HiRes/Manifest
new file mode 100644
index 000000000000..fcb0a30620a8
--- /dev/null
+++ b/dev-perl/DateTime-HiRes/Manifest
@@ -0,0 +1,4 @@
+AUX DateTime-HiRes-0.10.0-datetimelocale.patch 1233 BLAKE2B 1f65d1a7e9f30051a6f3bcb50a58afc05906c4cc43d158b280642803e08df1307ae6efa072b06a69ac6e454d8bc6b5664db6b9e801881ca2748f83497823acbb SHA512 765e619037e0aeadeee2bb4db685b4bcd9b622d4ec53c7e58f7f6c1af4ca46323cc533e8b64b44377f264ca0936450c678dd5dd75702c62acea1bdd37c4e5376
+DIST DateTime-HiRes-0.01.tar.gz 9982 BLAKE2B 4ffaa0a5aa10c61a4226e05488f24634db59127b7c9ceb8fdd692ec70d1a490a54bbbcc279a9c7b27e9870382164b3323516ffe1676f32192c4f0e6485e6245e SHA512 c84f0a415a28eb58158150373e577fa2cc852ea1f998b118822de328d2adab8800a0ed283beabb0c32abc36b1de90ad929f6c68096a8a27c50f08d9381468611
+EBUILD DateTime-HiRes-0.10.0-r1.ebuild 418 BLAKE2B fbdf2a0c498a06a93cade5713862af8cfac7c6b1203514815eedcf09156368bd50774b52fff131acb5cddf7cd822fc54137516db70d627a13aa7cadc8128fe72 SHA512 a20402c0a844c82b8a57746b8db1da8b1a3eff7ba76037fb5d1fbbb8a66fccd7543797f4689f7d9304741c9026a421cef947a042c9db774532767203a6246c6d
+MISC metadata.xml 400 BLAKE2B fe36398bc628001b297aff4c2afae1d5c8281d5e46dc1eb241f9424167fed3cd5f4eb71a8c201144db19522f73fa04cb13741c8ebe86f72e83dd79c387f21b87 SHA512 832c2458d2421204e70ba136eec9e23ec55f4f95e093ad2af92c4eb952c3ce87e3f27bee50c330c8ddd13d2658dda7a7e66f66d3a80c08e86cfbe3a8f57470d2
diff --git a/dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch b/dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch
new file mode 100644
index 000000000000..37847c4d5568
--- /dev/null
+++ b/dev-perl/DateTime-HiRes/files/DateTime-HiRes-0.10.0-datetimelocale.patch
@@ -0,0 +1,39 @@
+From 39dca8357ffbc562d1a4138586795a32e2a0c8ea Mon Sep 17 00:00:00 2001
+From: Roy Ivy III <rivy.dev@gmail.com>
+Date: Mon, 6 Jun 2016 14:03:59 -0500
+Subject: fix locale testing bug, accepting both old and new canonical locale
+ forms
+
+* fixes #1
+* fixes [rt-bug#109088]
+
+.# Discussion
+
+In v1.00, DateTime::Locale changed the canonical form of locale to use dashes instead of
+underscrores (see [1]). This causes a failure within the "t/02_now.t" test, blocking
+unforced installs.
+
+refs
+[1] https://github.com/autarch/DateTime-Locale/blob/v1.00/Changes#L44
+[rt-bug#109088] https://rt.cpan.org/Public/Bug/Display.html?id=109088 @@ https://archive.is/3RccB
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=109088
+Bug: https://github.com/jhoblitt/DateTime-HiRes/pull/2
+---
+ t/02_now.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/02_now.t b/t/02_now.t
+index 4eb1f74..fc55184 100644
+--- a/t/02_now.t
++++ b/t/02_now.t
+@@ -32,5 +32,5 @@ use DateTime::HiRes;
+ );
+
+ is( $dt->time_zone_long_name, 'Africa/Cairo', "accepted time_zone parameter" );
+- is( $dt->locale->id, 'ar_EG', "accepted locale parameter" );
++ like( $dt->locale->id, qr'ar[_-]EG', "accepted locale parameter" );
+ }
+--
+2.14.2
+
diff --git a/dev-perl/DateTime-HiRes/metadata.xml b/dev-perl/DateTime-HiRes/metadata.xml
new file mode 100644
index 000000000000..0726d4d59a5e
--- /dev/null
+++ b/dev-perl/DateTime-HiRes/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">DateTime-HiRes</remote-id>
+ <remote-id type="cpan-module">DateTime::HiRes</remote-id>
+ </upstream>
+</pkgmetadata>