summaryrefslogtreecommitdiff
path: root/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch')
-rw-r--r--dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch
new file mode 100644
index 000000000000..ab0fa2e133d8
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.010-unbundle.patch
@@ -0,0 +1,50 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 3c92f12..00ff4e3 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,5 @@
+ use 5.014000;
+ use ExtUtils::MakeMaker;
+-use Alien::cmake3;
+ use File::Spec::Functions qw/catfile/;
+ use Config;
+
+@@ -9,6 +8,12 @@ if ($Config{myuname} =~ /strawberry/i) {
+ $cmake_options = ($Config{cc} =~ /gcc/i) ? ' -G "MinGW Makefiles" ' : '';
+ }
+
++my $bundled = $ENV{IO_COMPRESS_BROTLI_BUNDLED} || 0;
++
++# Avoid unnecessary dependency
++use if $bundled, 'Alien::cmake3';
++
++
+ WriteMakefile(
+ NAME => 'IO::Compress::Brotli',
+ VERSION_FROM => 'lib/IO/Compress/Brotli.pm',
+@@ -23,6 +28,7 @@ WriteMakefile(
+ 'Getopt::Long' => '0',
+ 'Time::HiRes' => '0',
+ },
++ ( $bundled ) ? (
+ CONFIGURE_REQUIRES => {
+ 'Alien::cmake3' => '0',
+ },
+@@ -32,6 +38,9 @@ WriteMakefile(
+ INC => '-Ibrotli/c/include',
+ MYEXTLIB => 'brotli/libbrotlienc$(LIB_EXT) brotli/libbrotlidec$(LIB_EXT) brotli/libbrotlicommon$(LIB_EXT)',
+ clean => { FILES => 'brotli/Makefile brotli/libbrotlienc$(LIB_EXT) brotli/libbrotlidec$(LIB_EXT) brotli/libbrotlicommon$(LIB_EXT) brotli/CMakeCache.txt brotli/CMakeFiles/* brotli/CTestTestfile.cmake brotli/DartConfiguration.tcl brotli/brotli brotli/cmake_install.cmake brotli/libbrotlicommon.pc brotli/libbrotlidec.pc brotli/libbrotlienc.pc' },
++ ) : (
++ LIBS => ['-lbrotlienc -lbrotlidec'],
++ ),
+ META_ADD => {
+ dynamic_config => 0,
+ resources => {
+@@ -41,6 +50,7 @@ WriteMakefile(
+ );
+
+ sub MY::postamble {
++ return '' unless $bundled;
+ my @dirs = Alien::cmake3->bin_dir;
+ my $cmake = defined $dirs[0] ? catfile($dirs[0] , Alien::cmake3->exe) : Alien::cmake3->exe;
+ '