summaryrefslogtreecommitdiff
path: root/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Module-Pluggable/Module-Pluggable-5.200.0-r1.ebuild')
-rw-r--r--dev-perl/Module-Pluggable/Module-Pluggable-5.200.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0-r1.ebuild b/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0-r1.ebuild
new file mode 100644
index 000000000000..21ab867bf6df
--- /dev/null
+++ b/dev-perl/Module-Pluggable/Module-Pluggable-5.200.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SIMONW
+DIST_VERSION=5.2
+inherit perl-module
+
+DESCRIPTION="Automatically give your module the ability to have plugins"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-3
+ virtual/perl-if
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.620.0 )
+"