summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild')
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild
new file mode 100644
index 000000000000..130680148c73
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+HOMEPAGE="https://pear.php.net/package/Console_Getopt"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Console
+}