summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild')
-rw-r--r--dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild b/dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild
new file mode 100644
index 000000000000..7559f6ebd29c
--- /dev/null
+++ b/dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DESCRIPTION="Validation class"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-php/PEAR-PEAR dev-php/PEAR-Date )"
+RDEPEND="!minimal? ( dev-php/PEAR-Date )"
+#PATCHES=( "${FILESDIR}/0.8.5-fix-test-php7.patch" )
+HTML_DOCS=( docs/Example_Locale.php docs/sample_multiple.php )
+
+src_test() {
+ peardev run-tests tests || die
+}