summaryrefslogtreecommitdiff
path: root/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild')
-rw-r--r--dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild b/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
deleted file mode 100644
index eee581b20c2f..000000000000
--- a/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of accessible pygments styles"
-HOMEPAGE="
- https://pypi.org/project/accessible-pygments/
- https://github.com/Quansight-Labs/accessible-pygments/
-"
-SRC_URI="
- https://github.com/Quansight-Labs/accessible-pygments/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/pygments-1.5[${PYTHON_USEDEP}]
-"
-
-python_test() {
- # it's more like a demo but at least checks if all themes can
- # be loaded and run; we can't reasonably compare the results
- # because they differ by pygments version a lot
- "${EPYTHON}" test/run_tests.py || die
-}