summaryrefslogtreecommitdiff
path: root/dev-python/aiofiles/aiofiles-23.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiofiles/aiofiles-23.2.1.ebuild')
-rw-r--r--dev-python/aiofiles/aiofiles-23.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/aiofiles/aiofiles-23.2.1.ebuild b/dev-python/aiofiles/aiofiles-23.2.1.ebuild
new file mode 100644
index 000000000000..07e3521a9791
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-23.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest