summaryrefslogtreecommitdiff
path: root/dev-python/asdf/asdf-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asdf/asdf-1.2.1.ebuild')
-rw-r--r--dev-python/asdf/asdf-1.2.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/asdf/asdf-1.2.1.ebuild b/dev-python/asdf/asdf-1.2.1.ebuild
deleted file mode 100644
index 5a7e8cbaa666..000000000000
--- a/dev-python/asdf/asdf-1.2.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for the Advanced Scientific Data Format"
-HOMEPAGE="https://asdf.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-Disable-test-that-require-http-server.patch
-)
-
-python_prepare_all() {
- # use system astropy-helpers instead of bundled one
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- python_setup
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx --no-intersphinx
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}