summaryrefslogtreecommitdiff
path: root/dev-python/backrefs/backrefs-5.6_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/backrefs/backrefs-5.6_p1.ebuild')
-rw-r--r--dev-python/backrefs/backrefs-5.6_p1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/backrefs/backrefs-5.6_p1.ebuild b/dev-python/backrefs/backrefs-5.6_p1.ebuild
new file mode 100644
index 000000000000..2d4c68f012a6
--- /dev/null
+++ b/dev-python/backrefs/backrefs-5.6_p1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Wrapper around re or regex that adds additional back references"
+HOMEPAGE="
+ https://github.com/facelessuser/backrefs/
+ https://pypi.org/project/backrefs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest