summaryrefslogtreecommitdiff
path: root/dev-python/bokeh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/Manifest5
-rw-r--r--dev-python/bokeh/bokeh-0.11.1.ebuild60
-rw-r--r--dev-python/bokeh/bokeh-0.12.6.ebuild76
-rw-r--r--dev-python/bokeh/metadata.xml23
4 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
deleted file mode 100644
index cebee92ac176..000000000000
--- a/dev-python/bokeh/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST bokeh-0.11.1.tar.gz 3383140 BLAKE2B 68a368d7817e4066378018e6283177d5b8cc7e8328a9d2db0b678514016fd54c3d6c7d837e4df0ab0668539fe403a036cb660ea475aded6bbc685a138dffc087 SHA512 18cfee85698f1ba548c34fb223dc57e36584951064e65fac83cb8388b129914a8f67970a133ef2d1a67c06e50cbfb565a27d33dc9c90f5027a1739d400894706
-DIST bokeh-0.12.6.tar.gz 13720124 BLAKE2B e8fc1c42b530622bf6de8e13e81ae45e6d47985cef1ed81a2e32bfaef2a246a09c25210728cf434da6d4a0ef8f47ade1be5ee9e9318cc0a071bff36b317069a1 SHA512 7a293169521b690bb2cdcefe3667f869e75f2b718d6122af63201e2fb2e530eba931b3fa2ee3474a8ead758039cbb7d756acc0349e2f0820d72a4f754b9301b2
-EBUILD bokeh-0.11.1.ebuild 1976 BLAKE2B 8cc911f6f3a04377abd040e5e591aa5f98a4de75aed7501c1bfa6784fa927822c2411759553ed7f74ab40b6e662546451971d88ff4cbd0b44fc2432ef415850d SHA512 be33b62616fe13fc8d3c5f2a390143e929e57505169223e69ca4eb99c7f2357479560c8ca9bf100df8dc49fae30e2cc9360bb1b9141eaa7e696eb63901e26303
-EBUILD bokeh-0.12.6.ebuild 2137 BLAKE2B dda76af573d925a896da70fb990cf8f798b0fd6748deebd6c40354502bfaf663b196bde2064a4334b80e0f793f5f918fc07ade3f9fbaaac4e399a0a865d1b8f5 SHA512 e11b803c1d05a2f78af7b30dfd7a52d6ca3fa68a134df4af7bbe1c889c64f1e105fd6563a2f2206d1ce612849b05ec5bf6ed2e6f77486b50bffa5b68e86887a0
-MISC metadata.xml 879 BLAKE2B edcba4dfedb81192edd9a32b2ad320582129f0efdd9ccab46d99ebc0e561784f04f53fe1dd80243513ea0a69ab3dfeb1d36cda6a5b37585cc26e2c203194a8bc SHA512 46419cc11f266c9e5d51b35c4bd4a75c4c82446dc8a9f06b6ac7ef3c742a371334b56e98a4bc831bc4f5ccee0222ba7f2b36a44d32fc4ea3aaa092b32c7429c9
diff --git a/dev-python/bokeh/bokeh-0.11.1.ebuild b/dev-python/bokeh/bokeh-0.11.1.ebuild
deleted file mode 100644
index 3a98665a7293..000000000000
--- a/dev-python/bokeh/bokeh-0.11.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Statistical and novel interactive HTML plots for Python"
-HOMEPAGE="https://bokeh.pydata.org/en/latest/
- https://github.com/bokeh/bokeh
- https://pypi.org/project/bokeh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-# A doc build requires napoleon sphinx extension which will be included in sphinx release 1.3
-# Therefore refraining from adding the doc build for now
-RDEPEND="
- dev-python/abstract_rendering[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.2.7[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.11[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
- >=dev-python/redis-py-2.7.6[${PYTHON_USEDEP}]
- >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.9.1[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.0.1[${PYTHON_USEDEP}]
- "
-# testing server: needs websocket not in portage yet
-# websocket is in pypi for the adding
-# hdf5 backend: needs array management not in portage yet
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2*')
- $(python_gen_cond_dep 'dev-python/flexx[${PYTHON_USEDEP}]' 'python3*')
- )"
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- py.test -m 'not (js or examples or integration)' -vv || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/bokeh/bokeh-0.12.6.ebuild b/dev-python/bokeh/bokeh-0.12.6.ebuild
deleted file mode 100644
index e3483aea8436..000000000000
--- a/dev-python/bokeh/bokeh-0.12.6.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Statistical and interactive HTML plots for Python"
-HOMEPAGE="https://bokeh.pydata.org/en/latest/
- https://github.com/bokeh/bokeh
- https://pypi.org/project/bokeh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=net-libs/nodejs-4.1
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
- test? (
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/flexx[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/selenium[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )
-"
-
-python_compile() {
- esetup.py build --build-js
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- py.test -m 'not (js or examples or integration)' -vv || die
-}
-
-python_install_all() {
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples/"
- doins examples/*
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/bokeh/metadata.xml b/dev-python/bokeh/metadata.xml
deleted file mode 100644
index da849fdc2a30..000000000000
--- a/dev-python/bokeh/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- Bokeh is a Python interactive visualization library for large
- datasets that natively uses the latest web technologies. Its goal is
- to provide elegant, concise construction of novel graphics in the
- style of Protovis/D3, while delivering high-performance
- interactivity over large data to thin clients.
-</longdescription>
- <upstream>
- <remote-id type="pypi">bokeh</remote-id>
- <remote-id type="github">ContinuumIO/bokeh</remote-id>
- <maintainer status="unknown">
- <email>info@continuum.io</email>
- <name>Continuum Analytics</name>
- </maintainer>
- </upstream>
-</pkgmetadata>