summaryrefslogtreecommitdiff
path: root/dev-python/chameleon/chameleon-3.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chameleon/chameleon-3.9.1.ebuild')
-rw-r--r--dev-python/chameleon/chameleon-3.9.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/chameleon/chameleon-3.9.1.ebuild b/dev-python/chameleon/chameleon-3.9.1.ebuild
new file mode 100644
index 000000000000..3b8882cd9add
--- /dev/null
+++ b/dev-python/chameleon/chameleon-3.9.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="https://github.com/malthe/chameleon/
+ https://pypi.org/project/Chameleon/"
+SRC_URI="
+ https://github.com/malthe/chameleon/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd src || die
+ distutils-r1_src_test
+}