summaryrefslogtreecommitdiff
path: root/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coreapi/coreapi-2.3.3-r1.ebuild')
-rw-r--r--dev-python/coreapi/coreapi-2.3.3-r1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/coreapi/coreapi-2.3.3-r1.ebuild b/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
index 6b899647835f..f1d85bb66162 100644
--- a/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
+++ b/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
@@ -1,15 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
+MY_P=python-client-${PV}
DESCRIPTION="Python client library for Core API"
HOMEPAGE="https://github.com/core-api/python-client"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/core-api/python-client/archive/${PV}.tar.gz
+ -> core-api-${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
@@ -19,5 +22,5 @@ RDEPEND="dev-python/coreschema[${PYTHON_USEDEP}]
dev-python/itypes[${PYTHON_USEDEP}]
dev-python/uritemplate[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest