summaryrefslogtreecommitdiff
path: root/dev-python/coreschema/coreschema-0.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coreschema/coreschema-0.0.4.ebuild')
-rw-r--r--dev-python/coreschema/coreschema-0.0.4.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/coreschema/coreschema-0.0.4.ebuild b/dev-python/coreschema/coreschema-0.0.4.ebuild
index c9e4efbc99e9..a4c0e7af886b 100644
--- a/dev-python/coreschema/coreschema-0.0.4.ebuild
+++ b/dev-python/coreschema/coreschema-0.0.4.ebuild
@@ -1,20 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
+MY_P=python-${P}
DESCRIPTION="Core Schema"
HOMEPAGE="https://github.com/core-api/python-coreschema"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/core-api/python-coreschema/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest