summaryrefslogtreecommitdiff
path: root/dev-python/css-parser/css-parser-1.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/css-parser/css-parser-1.0.6.ebuild')
-rw-r--r--dev-python/css-parser/css-parser-1.0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/css-parser/css-parser-1.0.6.ebuild b/dev-python/css-parser/css-parser-1.0.6.ebuild
new file mode 100644
index 000000000000..ccc51564195c
--- /dev/null
+++ b/dev-python/css-parser/css-parser-1.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library (fork of cssutils)"
+HOMEPAGE="https://pypi.org/project/css-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10-test.patch"
+)
+
+distutils_enable_tests setup.py