summaryrefslogtreecommitdiff
path: root/dev-python/distro/distro-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/distro/distro-1.0.4.ebuild')
-rw-r--r--dev-python/distro/distro-1.0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/distro/distro-1.0.4.ebuild b/dev-python/distro/distro-1.0.4.ebuild
new file mode 100644
index 000000000000..5953b7c8d536
--- /dev/null
+++ b/dev-python/distro/distro-1.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="http://distro.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # incomplete test resources
+
+python_test() {
+ py.test || die
+}