summaryrefslogtreecommitdiff
path: root/dev-python/django-otp/django-otp-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-otp/django-otp-1.0.3.ebuild')
-rw-r--r--dev-python/django-otp/django-otp-1.0.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/django-otp/django-otp-1.0.3.ebuild b/dev-python/django-otp/django-otp-1.0.3.ebuild
deleted file mode 100644
index 26c9a4b8f2af..000000000000
--- a/dev-python/django-otp/django-otp-1.0.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
-HOMEPAGE="https://github.com/django-otp/django-otp/"
-SRC_URI="
- https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-2.2[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_test() {
- local -x PYTHONPATH=test:${PYTHONPATH}
- local -x DJANGO_SETTINGS_MODULE=test_project.settings
- django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
-}