summaryrefslogtreecommitdiff
path: root/dev-python/docutils/docutils-0.20.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docutils/docutils-0.20.1-r1.ebuild')
-rw-r--r--dev-python/docutils/docutils-0.20.1-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/docutils/docutils-0.20.1-r1.ebuild b/dev-python/docutils/docutils-0.20.1-r1.ebuild
index b6e73efa09cc..cca31d549b55 100644
--- a/dev-python/docutils/docutils-0.20.1-r1.ebuild
+++ b/dev-python/docutils/docutils-0.20.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit distutils-r1 pypi
+inherit distutils-r1 optfeature pypi
DESCRIPTION="Python Documentation Utilities (reference reStructuredText impl.)"
HOMEPAGE="
@@ -71,3 +71,9 @@ python_install_all() {
install_txt_doc "${doc}"
done < <(find docs tools -name '*.txt' -print0)
}
+
+pkg_postinst() {
+ optfeature \
+ "auto-detecting the image dimensions when using the 'scale' option" \
+ dev-python/pillow
+}