summaryrefslogtreecommitdiff
path: root/dev-python/doit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest1
-rw-r--r--dev-python/doit/doit-0.36.0-r2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index 3557bb51233c..114dfd1b98e2 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,3 +1,4 @@
DIST doit-0.36.0.tar.gz 1448096 BLAKE2B 15558a39ccac031ddf3a429aa585bc6e1d49c2e7572df29979ca66d1025fa5d7a917f6cc5bcfd21f2749e4ed7e7885b0865ec67b6fa32817e1518d47da9ead97 SHA512 d4caa31701755c7f59213dde0f89fd3616c0c01b7f06245cbfd9f1a315d503e62f3556c3b86685cd0ebfcffcc9cae0987ca150f037aa7b3cd960439a1191be42
EBUILD doit-0.36.0-r1.ebuild 1519 BLAKE2B 83e578d2f603a5b5a081662d27ee83d19f5119856afd8fa44bed54d743a1d76a9bda4494e4893d40a104fff26322ed5dbbd61400c1c7c2e353dee61a33801759 SHA512 bc5af4ce5b9c62fb677ec0ebce6fbefadd3405b71e52e440455bc06b5bf94d05f6e5ac7060a37042fac84d1b942bd8b06043ecd8752983cc006a77886f80831a
+EBUILD doit-0.36.0-r2.ebuild 1560 BLAKE2B c3d78eee1a4a06342fe2106fecb4e4dd5c8c761e91784f23ae42fde7670a989359ab6be763e6dd914a8301a324cc9a67e0c08c035cd06fd264e178dcd1f187b1 SHA512 b36fd545a32aa548fc94ce1cbe3617b9ba7ec5b4f02132ddf475b1f6e7144f0aeb421e8cbaddb3849595b6b3fc76d4c57f07f1d90d88003c83fc08eede468aa4
MISC metadata.xml 568 BLAKE2B add52a6e7986bb88b9dc87d2f03c4ec3716ae7d5e2402556b7a3137b8267ca2cad0ae3324d628f3127afde36513414029c0f567a9683dd9b11b1a287ff5e3a7d SHA512 e772c9ccd8133fd73dcf04733facf60ef7c2f1559b83e5024faeea4d5fd7799c42a28be6c9b8676ea9b6d68969ca5be633320e8cb7dd8d1f0dca35e819eaebc7
diff --git a/dev-python/doit/doit-0.36.0-r2.ebuild b/dev-python/doit/doit-0.36.0-r2.ebuild
new file mode 100644
index 000000000000..37fc353b936c
--- /dev/null
+++ b/dev-python/doit/doit-0.36.0-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="
+ https://pydoit.org/
+ https://github.com/pydoit/doit/
+ https://pypi.org/project/doit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ || (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+ ' 3.10)
+"
+PDEPEND="
+ >=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ $(python_gen_impl_dep sqlite)
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # test failing due to impact on PATH run in a sandbox
+ tests/test_cmd_strace.py::TestCmdStrace::test_dep # #836164
+ tests/test_cmd_strace.py::TestCmdStrace::test_target
+)
+
+src_prepare() {
+ # Replace custom theme with builtin for documentation
+ sed -e '/html_theme/s/press/sphinx_rtd_theme/' -i doc/conf.py || die
+ # Remove non-exist modules for doc generation (#832754)
+ sed \
+ -e '/sphinx_sitemap/d' \
+ -e '/sphinx_reredirects/d' \
+ -i doc/conf.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp bash_completion_doit ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins zsh_completion_doit _${PN}
+}