summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
index 69b970850c57..e52f1f75567e 100644
--- a/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
+++ b/dev-python/google-api-python-client/google-api-python-client-2.8.0.ebuild
@@ -32,11 +32,16 @@ BDEPEND="
dev-python/oauth2client[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/parameterized[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
)"
distutils_enable_tests --install pytest
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
python_test() {
local deselect=(
# require Internet access (and credentials)