summaryrefslogtreecommitdiff
path: root/dev-python/hidapi/hidapi-0.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hidapi/hidapi-0.13.1.ebuild')
-rw-r--r--dev-python/hidapi/hidapi-0.13.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/hidapi/hidapi-0.13.1.ebuild b/dev-python/hidapi/hidapi-0.13.1.ebuild
deleted file mode 100644
index c1a9212c3318..000000000000
--- a/dev-python/hidapi/hidapi-0.13.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Cython interface to HIDAPI library"
-HOMEPAGE="https://github.com/trezor/cython-hidapi"
-
-LICENSE="|| ( BSD GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-DEPEND=">=dev-libs/hidapi-$(ver_cut 1-3)"
-RDEPEND="${DEPEND}"
-# <cython-3 for bug #898678
-BDEPEND="<dev-python/cython-3[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_configure_all() {
- DISTUTILS_ARGS=( --with-system-hidapi )
-}
-
-python_test() {
- epytest tests.py
-}