summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/httpbin-0.7.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpbin/httpbin-0.7.0-r3.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r3.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/httpbin/httpbin-0.7.0-r3.ebuild b/dev-python/httpbin/httpbin-0.7.0-r3.ebuild
deleted file mode 100644
index 99f8b0295ddd..000000000000
--- a/dev-python/httpbin/httpbin-0.7.0-r3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP Request and Response Service"
-HOMEPAGE="https://github.com/postmanlabs/httpbin
- https://pypi.org/project/httpbin/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.14.1[${PYTHON_USEDEP}]"
-
-PATCHES=(
- # do not import raven if it's not going to be used
- # (upstream removed it completely in git anyway)
- "${FILESDIR}"/httpbin-0.7.0-optional-raven.patch
- # fix tests with new versions of werkzeug
- "${FILESDIR}"/httpbin-0.7.0-test-werkzeug.patch
- # use brotlicffi instead of brotlipy
- "${FILESDIR}"/httpbin-0.7.0-brotlicffi.patch
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # a new version of flask or whatever converts relative redirects
- # to absolute; this package is dead anyway, so just skip
- # the relevant tests
- sed -e 's:test_redirect:_&:' \
- -e 's:test_relative:_&:' \
- -i test_httpbin.py || die
-
- distutils-r1_src_prepare
-}