summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources/importlib_resources-5.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/importlib_resources/importlib_resources-5.10.2.ebuild')
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.10.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-5.10.2.ebuild b/dev-python/importlib_resources/importlib_resources-5.10.2.ebuild
index ddcd02a543b7..c940531e0171 100644
--- a/dev-python/importlib_resources/importlib_resources-5.10.2.ebuild
+++ b/dev-python/importlib_resources/importlib_resources-5.10.2.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7
DISTUTILS_USE_PEP517=flit
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 )
+# This is a backport of importlib.resources that's present since py3.9.
+# However, the version in 3.9 is buggy, so matplotlib needs it on 3.9
+# as well.
+PYTHON_COMPAT=( pypy3 python3_9 )
inherit distutils-r1