summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-test/jaraco-test-5.2.0.ebuild')
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
new file mode 100644
index 000000000000..8b5ed987f9b2
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest