summaryrefslogtreecommitdiff
path: root/dev-python/kiwi/kiwi-1.9.39.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kiwi/kiwi-1.9.39.2.ebuild')
-rw-r--r--dev-python/kiwi/kiwi-1.9.39.2.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/kiwi/kiwi-1.9.39.2.ebuild b/dev-python/kiwi/kiwi-1.9.39.2.ebuild
deleted file mode 100644
index 7ae149f76646..000000000000
--- a/dev-python/kiwi/kiwi-1.9.39.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator virtualx
-
-DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
-HOMEPAGE="https://launchpad.net/kiwi
- https://pypi.org/project/kiwi-gtk/"
-MY_PN="${PN}-gtk"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND=">=dev-python/setuptools-0.8[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- testing() {
- "${PYTHON}" -m unittest discover || die "tests failed"
- }
- VIRTUALX_COMMAND=virtualmake testing
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
- rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
-}