summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler/line_profiler-4.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/line_profiler/line_profiler-4.0.3.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-4.0.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/line_profiler/line_profiler-4.0.3.ebuild b/dev-python/line_profiler/line_profiler-4.0.3.ebuild
index 2cf016dcb0a6..bb034b04c80c 100644
--- a/dev-python/line_profiler/line_profiler-4.0.3.ebuild
+++ b/dev-python/line_profiler/line_profiler-4.0.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -26,8 +26,9 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/ipython[${PYTHON_USEDEP}]
"
+# <cython-3: https://bugs.gentoo.org/911735
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/ubelt[${PYTHON_USEDEP}]