summaryrefslogtreecommitdiff
path: root/dev-python/lxml/lxml-4.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lxml/lxml-4.6.3.ebuild')
-rw-r--r--dev-python/lxml/lxml-4.6.3.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/lxml/lxml-4.6.3.ebuild b/dev-python/lxml/lxml-4.6.3.ebuild
index f600d3a5f551..56111fe84a47 100644
--- a/dev-python/lxml/lxml-4.6.3.ebuild
+++ b/dev-python/lxml/lxml-4.6.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1 optfeature toolchain-funcs
@@ -20,13 +20,12 @@ RESTRICT="!test? ( test )"
# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
RDEPEND="
- >=dev-libs/libxml2-2.9.5
+ <dev-libs/libxml2-2.9.12
>=dev-libs/libxslt-1.1.28"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
$(python_gen_any_dep '
dev-python/docutils[${PYTHON_USEDEP}]