summaryrefslogtreecommitdiff
path: root/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild')
-rw-r--r--dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild b/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..189d6e2c00d9
--- /dev/null
+++ b/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="The python implementation of the MMTF API, decoder and encoder"
+HOMEPAGE="http://mmtf.rcsb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${BDEPEND}"