summaryrefslogtreecommitdiff
path: root/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-remote/neovim-remote-2.4.0.ebuild')
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.4.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild b/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild
new file mode 100644
index 000000000000..e8e8df1ecd2e
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pynvim[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+BDEPEND+="
+ test? ( app-editors/neovim )
+"