summaryrefslogtreecommitdiff
path: root/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild')
-rw-r--r--dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
new file mode 100644
index 000000000000..e564c8306957
--- /dev/null
+++ b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of Noise Protocol Framework. Compatible with revisions 32 and 33."
+HOMEPAGE="https://pypi.org/project/noiseprotocol"
+SRC_URI="https://github.com/plizonczyk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ rm -r "examples" || die "rm failed"
+}