summaryrefslogtreecommitdiff
path: root/dev-python/pastescript
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/Manifest1
-rw-r--r--dev-python/pastescript/pastescript-2.0.2.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/pastescript/Manifest b/dev-python/pastescript/Manifest
index 5d97697c8384..b02e3f81080c 100644
--- a/dev-python/pastescript/Manifest
+++ b/dev-python/pastescript/Manifest
@@ -1,4 +1,3 @@
DIST PasteScript-2.0.2.tar.gz 117521 BLAKE2B 2de72050ee7f5b7037b99f9661b5445e523607afc84a8846f0e5d9e89196e302627f552825ce0e4f821b7ed9ed2713c87d7b504a4e2abf092f1e8fa014c40c4b SHA512 2f093eb982972fed354219c75c2e008931cea553960cea8aaafbe57cde8556de5626e7eb9bb3b9b7328bad3b7d9899f11fc9773a65380396dae506e7531516de
EBUILD pastescript-2.0.2-r1.ebuild 1321 BLAKE2B 9608713377895d8ba19c9f30eb5116abc3f53a96769973c53e88341d3ea8cfb85527db81ec27b88b93bb991c8022b001b90a93dc5afb3275db8527b436b27ad0 SHA512 3feca93a4d9cf5712c874eca4f43c5ad3d937a9fc12f7c37be5e3118cec2ce1d0f8aa8c62e4c1f4e419e74c02f4177a088aae2d572256e3210b5c259b10bee0f
-EBUILD pastescript-2.0.2.ebuild 1226 BLAKE2B db07fe5cf86a598540139dec84b75fb0ad4a75495cf862900d09f923f4f64ee0713f1f72e0cadcf536f44cc2eec0b38ac209f8d14b5401d6f718235f42966654 SHA512 e8dc8003d847b4c53a87f8ffcac9dd152c6defdc5e51bab5ae891d042e9b6a358f9cb63ac0ff83e72c12e237adcb8fb89bb81dcd767ff91a2a8904496287e92c
MISC metadata.xml 324 BLAKE2B ef67daa0f9e2595c0b35ed1b919c98129443d224c81a7ea6bd0ef919845339dd9cd45ea96ff4a4aa0176b24c61a57bc2cf8ee2f0c2d10386dbae1c904d5426ab SHA512 48a93ec635e32513438b44cb67bd7302c6bc55c72281d253ee4cd4b0a7d4c25ec61b028d861fa1acd2b40f22479fc0a1f726d3334c8a2970ad2b45729279ec47
diff --git a/dev-python/pastescript/pastescript-2.0.2.ebuild b/dev-python/pastescript/pastescript-2.0.2.ebuild
deleted file mode 100644
index f47206a3675f..000000000000
--- a/dev-python/pastescript/pastescript-2.0.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-MY_PN="PasteScript"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
-HOMEPAGE="http://pythonpaste.org/script/ https://pypi.python.org/pypi/PasteScript"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/paste-1.3[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests are broken.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- nosetests -v -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use doc; then
- cd "${BUILD_DIR}"/sphinx/html || die
- dohtml -r [a-z]* _static
- fi
-}