summaryrefslogtreecommitdiff
path: root/dev-python/piexif/piexif-1.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/piexif/piexif-1.1.3.ebuild')
-rw-r--r--dev-python/piexif/piexif-1.1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/piexif/piexif-1.1.3.ebuild b/dev-python/piexif/piexif-1.1.3.ebuild
new file mode 100644
index 000000000000..156df0a63aa1
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.org/project/piexif/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow )"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" setup.py test
+}