summaryrefslogtreecommitdiff
path: root/dev-python/pipdeptree
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipdeptree')
-rw-r--r--dev-python/pipdeptree/Manifest3
-rw-r--r--dev-python/pipdeptree/files/pipdeptree-2.13.2-fix-pypy-7.3.14.patch37
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.13.2.ebuild43
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/Manifest b/dev-python/pipdeptree/Manifest
index f9566f0f8be3..e9e82a75d84f 100644
--- a/dev-python/pipdeptree/Manifest
+++ b/dev-python/pipdeptree/Manifest
@@ -1,4 +1,7 @@
AUX pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch 1018 BLAKE2B 18405bf1f1ba5a457c9643738258df5d1c3d5ed709954dd274560ae9cbf139f336b75b2c896d9d8bdfe24c4d2cb98ea3e0391d73ac05ba1e38766f2cfa04a431 SHA512 da732fe18cc3f49ed3994133e8a5eefe4c6f8ebf18dad3caeb057bcdbab38f5936c245271d6ff534f3cb6069255e13291a9033594148e70e486fd85d5b9e711e
+AUX pipdeptree-2.13.2-fix-pypy-7.3.14.patch 1353 BLAKE2B 5e3a6f53244de1ae185818e3e2a37a87229b46b02c390a606b65668ae1dc53fe1a6b5e6c9faaf6160f25adc7e2597cceb5fd89bb20414a609880e034c7bdc026 SHA512 e0e8e729d713d347c96ee7db5e6a14ba7a9a986aa41231731973b4ab31f8d866cd4d229b35b54411e171a446d61201675ab3df01a58079786eabf5a080de05ad
DIST pipdeptree-2.13.1.tar.gz 33139 BLAKE2B e7044303f09ad3952e14f79ec11e01a54e9c34ff5b4430094a968602c8a97388eadd4e021c97c97c1767d7ae02b7070ff6e4ec934aef6036b98bf2553d2344a0 SHA512 18c73a8ef458b0a241d967da40453fb8a9fc6550cbd2c21eecca9a81f011b896622fb45a81b79e30eb990454b6f518a1fcc02cb25bb2c5ca988b44e040264e26
+DIST pipdeptree-2.13.2.tar.gz 33290 BLAKE2B 1b97dbfaa6f6baff272e6e6d5399f95b96e13b19bba5ef3997574d027002abd98152e26d67b4b19555392d076c84bf6b142d147d95349ba1dd535bea40994b4f SHA512 ce6cfc29827c087725366a95079621516303cf50c6c4ee4a0cd5d8b7649e8dd7b7145b62523c48731a2b5f4140c90c558eb5d1a0248b28a8c4c97ccb78d9e16d
EBUILD pipdeptree-2.13.1.ebuild 946 BLAKE2B d94327ac52ab9d2d4b9f48c0ed39ae72444b123638eed543ba9d13af8d6eb04fa7ace0f5225d14d84de9da1b9185a3b4fb4440549970361989c4c050501f9629 SHA512 d66ffc621fc4fee975c7d2829350bc99c295d285f17b1bb5197c56d83b755ccf0d42ca6328b5e0808ece7e2372a9635734b2797d1b216861356e6df4425f4186
+EBUILD pipdeptree-2.13.2.ebuild 1001 BLAKE2B 353933b6854bcd9f62299cc3932e5256028cacf9dc5a62c6cbfb546524b4553c8c860c3f43fc9f819dbc89c0ed0a82d63762b6624d8388aace92fd79563e6ff2 SHA512 0c497bfee60c2ae4aa8d11d347190d180630e2753c20f8d8f93546de184fa165738dd7fb52554ca09d0d7a9c70bca060529ef943cf91f07483827749d335ca88
MISC metadata.xml 545 BLAKE2B cf435473fd95ac0a5bafe2b52ddd78e09c16eb190e3a979924525607fc7ab152e249419e3a21d246cd1354a714116c6c0953ed55d1efceafae441ee282c2b1eb SHA512 ad2e8d4e7bac53b26ea0bb5c2f65e0c9dc8d30afc8c569d73bac820b2dda6a343b96e52abd0353e3f50269fb431e46bd3b51b3768d9c24f658fd2eca6cc1ce97
diff --git a/dev-python/pipdeptree/files/pipdeptree-2.13.2-fix-pypy-7.3.14.patch b/dev-python/pipdeptree/files/pipdeptree-2.13.2-fix-pypy-7.3.14.patch
new file mode 100644
index 000000000000..3718174d0af6
--- /dev/null
+++ b/dev-python/pipdeptree/files/pipdeptree-2.13.2-fix-pypy-7.3.14.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/923893
+
+From 5d111ebe3bb1d24baa314b615d67d3e3928297ca Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Wed, 7 Feb 2024 08:47:03 +0200
+Subject: [PATCH] Use json output for test which parses installed packages
+
+* pypy bundles hpy which has a dependency on setuptools, therefore
+ breaking non-json output due sub-dependency pretty printing.
+* Using json makes parsing dependencies straight forward.
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/tests/test_non_host.py
++++ b/tests/test_non_host.py
+@@ -1,5 +1,6 @@
+ from __future__ import annotations
+
++import json
+ import sys
+ from platform import python_implementation
+ from typing import TYPE_CHECKING
+@@ -25,10 +26,10 @@ def test_custom_interpreter(
+ monkeypatch.chdir(tmp_path)
+ py = str(result.creator.exe.relative_to(tmp_path))
+ cmd += [f"--python={result.creator.exe}"] if args_joined else ["--python", py]
+- monkeypatch.setattr(sys, "argv", cmd)
++ monkeypatch.setattr(sys, "argv", [*cmd, "-j"])
+ main()
+ out, _ = capfd.readouterr()
+- found = {i.split("==")[0] for i in out.splitlines()}
++ found = {i["package"]["package_name"] for i in json.loads(out)}
+ implementation = python_implementation()
+ if implementation == "CPython":
+ expected = {"pip", "setuptools", "wheel"}
+--
+2.43.0
+
diff --git a/dev-python/pipdeptree/pipdeptree-2.13.2.ebuild b/dev-python/pipdeptree/pipdeptree-2.13.2.ebuild
new file mode 100644
index 000000000000..88a5c229f6a9
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.13.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/tox-dev/pipdeptree/pull/302
+ "${FILESDIR}/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch"
+ "${FILESDIR}/pipdeptree-2.13.2-fix-pypy-7.3.14.patch"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}