summaryrefslogtreecommitdiff
path: root/dev-python/pylint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest4
-rw-r--r--dev-python/pylint/pylint-3.0.1.ebuild83
-rw-r--r--dev-python/pylint/pylint-3.0.2.ebuild17
3 files changed, 15 insertions, 89 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 7007aedd7875..7c7fe79b2ac2 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,3 @@
-DIST pylint-3.0.1.gh.tar.gz 1419203 BLAKE2B 6a1c3db074c39a6cd838b39db13650192eb08b95210b95a78e518f9a2cf6c22b92c691f52c6fc08fff5363b12f028897d512f92de7fafabcbdfaeb18ae5535f9 SHA512 c8eca77f70a794e9dc764a70107afdd684a873ab00d6f51d400b96f6e06a39db014a27ef0505f2f7a370e5457e5061c78d2aab4fe1bf59746db4bbe3ae102423
DIST pylint-3.0.2.gh.tar.gz 1420866 BLAKE2B 2679810940ee5b4a4dcde5a4a3d70052901d6ca8dfd025708fdfe3fadffc7713d3507eaea9a67a2fc0748478e8b6e2c2e66e487bf93749fcd9fea7d070197b16 SHA512 923fab3681aa266aa633cc122cd2076dc73588191ed116da0e83d9d0cff253c93634dd420d32b5ea780c25a8e9ff526d8393d4eae2e046a2ff82df3f5f9322a4
-EBUILD pylint-3.0.1.ebuild 2115 BLAKE2B 8947c56cc1751a4cfbaf5510f2aa97b0f06bd80204808887cc756dd66e283e30069c6730d0f25d33d78a2d48ce7b929a7b49a8c704b5e1eea5ca56417b24c309 SHA512 74ef9f80b447f85089c077408b78966afbdb37f1ace84b07075725b594785dfc485ca7c23716e90921061a42e694af9d1fb7a2e30a08db189189e7be96260451
-EBUILD pylint-3.0.2.ebuild 2123 BLAKE2B 5ca1c0cf2fd831abe792b6f63bf655a0910aa33bff9f66373b59e0e70e32c659fe1a2539c8a36f434bbf39ecb363c0264fc0f385804668d1286dc67f2b79db89 SHA512 5700b0c5a42e647a479c8ca236e1fe8a80604db9d7352cab3ed56609051bd3c20c98c5003a5acc66af9ef1cf242359297548922ba5c690361da18e1321a99c6e
+EBUILD pylint-3.0.2.ebuild 2396 BLAKE2B c986caa5a26385d265a5a3ebb152b7f3a6570c39f61cddd39acf0ee2acf18c8246b6d66799e809151ccd7eaf819d0d48bb159ee176aa35348d3d7c39bc1ec726 SHA512 bea3b36f79cead5e51b251503c5c28e70abf686be72d18605fe473e81532c8c23bbc8b9bac792f6641dfd516c77b52b851fd9f59a3b2a0c9b02ff9974685a0e4
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-3.0.1.ebuild b/dev-python/pylint/pylint-3.0.1.ebuild
deleted file mode 100644
index 789ef0ed3637..000000000000
--- a/dev-python/pylint/pylint-3.0.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
-# Adjust dep bounds!
-RDEPEND="
- <dev-python/astroid-3.1[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
-
- # incompatible versions of numpy/scikit-learn?
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pylint/pylint-3.0.2.ebuild b/dev-python/pylint/pylint-3.0.2.ebuild
index af67a8803049..45c911979549 100644
--- a/dev-python/pylint/pylint-3.0.2.ebuild
+++ b/dev-python/pylint/pylint-3.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
@@ -44,7 +44,9 @@ RDEPEND="
"
BDEPEND="
test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
@@ -66,6 +68,15 @@ python_test() {
tests/benchmark/test_baseline_benchmarks.py
)
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # Requires GitPython
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
rm -rf pylint || die
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1