summaryrefslogtreecommitdiff
path: root/dev-python/pynest2d/pynest2d-4.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynest2d/pynest2d-4.12.1.ebuild')
-rw-r--r--dev-python/pynest2d/pynest2d-4.12.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pynest2d/pynest2d-4.12.1.ebuild b/dev-python/pynest2d/pynest2d-4.12.1.ebuild
new file mode 100644
index 000000000000..f6c4eeb7065b
--- /dev/null
+++ b/dev-python/pynest2d/pynest2d-4.12.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Python bindings for libnest2d"
+HOMEPAGE="https://github.com/Ultimaker/pynest2d"
+SRC_URI="https://github.com/Ultimaker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libnest2d
+ $(python_gen_cond_dep '<dev-python/sip-5[${PYTHON_USEDEP}]')
+ "
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.12.1-required-flags-from-Libnest2D-target.patch
+)