summaryrefslogtreecommitdiff
path: root/dev-python/pyrqlite/pyrqlite-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-9999.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-9999.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-9999.ebuild b/dev-python/pyrqlite/pyrqlite-9999.ebuild
deleted file mode 100644
index 0ead7f8d41c6..000000000000
--- a/dev-python/pyrqlite/pyrqlite-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
-fi
-
-DESCRIPTION="Python client for rqlite"
-EGIT_REPO_URI="https://github.com/rqlite/pyrqlite.git"
-HOMEPAGE="https://github.com/rqlite/pyrqlite"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- )"
-
-src_prepare() {
- sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- esetup.py test || die "tests failed"
- esetup.py lint -f text -E || die "pylint failed"
-}