summaryrefslogtreecommitdiff
path: root/dev-python/pyspf
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/Manifest2
-rw-r--r--dev-python/pyspf/pyspf-2.0.14.ebuild31
2 files changed, 20 insertions, 13 deletions
diff --git a/dev-python/pyspf/Manifest b/dev-python/pyspf/Manifest
index 1a061766a7ce..51eccece360d 100644
--- a/dev-python/pyspf/Manifest
+++ b/dev-python/pyspf/Manifest
@@ -1,3 +1,3 @@
DIST pyspf-2.0.14.tar.gz 69446 BLAKE2B 95a3bf89ab85aad84dcbbe81ada7f19d23cc689893df1d1317c0e06eb1f6b6d21b1e805d68e7c0c84161d711b9c6067f115d78c8786ce384036f7d0c425269b9 SHA512 ca801a899a80c18cd2c6bb8c125817c29898189805040cce8d29ace7a5aa34b43b9d10545150a1f39abd7bc49cd8da4fe753a04ac9b911e7bb9d77473753eeee
-EBUILD pyspf-2.0.14.ebuild 822 BLAKE2B 3dd0ae5ab746f3bae58649b38763a7cfc468fd39c46b40c52d05927f6cc406233370efa30fe2d4eba9baa860cb7c2bfeab5220ab7da53b658a39038d562fb422 SHA512 e019d402f8882251245dddc9d0239ef7bd5f400044136c7427672443758ce65d3b2e4ea77c05644e6f8a2f2fccfabb0d0f444cbc84966dfb0a5a09bbf42fd925
+EBUILD pyspf-2.0.14.ebuild 835 BLAKE2B 15caa46874a8a82d9c5d0080d2f6554ba0d4bb3f2a52ef4be8a75e529d88d86482a72ed964460c276d0dc6db732d8ceadd6f66426d46892a3b950bd2594d2868 SHA512 0339feefc32edd0ebc2d4573f13d1f3b2f0b004aa10aaf565b4267c04db89bd3d2ce23c9dc8be6a04b6c2434b81471644234514bf51001d5ddd8c15eaaeb0a74
MISC metadata.xml 318 BLAKE2B 428f1f97b1e20927edbd26d3cb405e242e2bdc4c2cd301b9dd7999570b0ffb5af1c786a6cf596917d6d2694e29cf47c3809d3af97adb078064dc3562fe2690e1 SHA512 561cbdd0b14a8fb091ba9943987d93c8c1323a4b5f8f2b32f094284d683eec5562153a5a8ec77412a0806bac56c5667ec6e9e8d99e77bc2e45a5b7d517c8c483
diff --git a/dev-python/pyspf/pyspf-2.0.14.ebuild b/dev-python/pyspf/pyspf-2.0.14.ebuild
index 97a34c45d65f..ca804235f393 100644
--- a/dev-python/pyspf/pyspf-2.0.14.ebuild
+++ b/dev-python/pyspf/pyspf-2.0.14.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE="ipv6?"
DISTUTILS_USE_SETUPTOOLS=no
@@ -17,19 +17,26 @@ LICENSE="PSF-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="ipv6 test"
+REQUIRED_USE="test? ( ipv6 )"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
- || ( dev-python/pydns:3[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}] )"
-
-DEPEND="test? ( ${RDEPEND}
- dev-python/pyyaml[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="test? ( ipv6 )"
+RDEPEND="
+ dev-python/authres[${PYTHON_USEDEP}]
+ || (
+ dev-python/pydns:3[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
python_test() {
- pushd test &> /dev/null
+ pushd test &> /dev/null || die
"${PYTHON}" testspf.py || die
- popd &> /dev/null
+ popd &> /dev/null || die
}