summaryrefslogtreecommitdiff
path: root/dev-python/python-vlc/python-vlc-3.0.20123.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-vlc/python-vlc-3.0.20123.ebuild')
-rw-r--r--dev-python/python-vlc/python-vlc-3.0.20123.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-vlc/python-vlc-3.0.20123.ebuild b/dev-python/python-vlc/python-vlc-3.0.20123.ebuild
new file mode 100644
index 000000000000..439e4eb3f722
--- /dev/null
+++ b/dev-python/python-vlc/python-vlc-3.0.20123.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python ctypes-based bindings for libvlc"
+HOMEPAGE="https://github.com/oaubert/python-vlc
+ https://wiki.videolan.org/Python_bindings/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/vlc
+"