summaryrefslogtreecommitdiff
path: root/dev-python/reno/reno-3.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/reno/reno-3.5.0.ebuild')
-rw-r--r--dev-python/reno/reno-3.5.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/reno/reno-3.5.0.ebuild b/dev-python/reno/reno-3.5.0.ebuild
deleted file mode 100644
index 29246b1b609f..000000000000
--- a/dev-python/reno/reno-3.5.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
-HOMEPAGE="https://pypi.org/project/reno/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc64 ~riscv ~s390 x86"
-
-RDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
- >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
- >=dev-python/sphinx-2.1.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- )
-"
-
-# The doc needs to be built from a git repository
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # Some tests need to be run from a git repository
- rm reno/tests/test_{cache,semver}.py || die
- distutils-r1_python_prepare_all
-}