summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache/requests-cache-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-cache/requests-cache-1.1.1.ebuild')
-rw-r--r--dev-python/requests-cache/requests-cache-1.1.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/requests-cache/requests-cache-1.1.1.ebuild b/dev-python/requests-cache/requests-cache-1.1.1.ebuild
index b5f675e3aaba..605e560b1a0b 100644
--- a/dev-python/requests-cache/requests-cache-1.1.1.ebuild
+++ b/dev-python/requests-cache/requests-cache-1.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 optfeature
@@ -62,6 +62,13 @@ python_test() {
)
case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # "database is locked", upstream probably relies on GC
+ # too much
+ tests/integration/test_sqlite.py
+ )
+ ;;
python3.12)
# https://github.com/requests-cache/requests-cache/issues/845
EPYTEST_DESELECT+=(