summaryrefslogtreecommitdiff
path: root/dev-python/s3transfer/s3transfer-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.2.0.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.2.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.2.0.ebuild b/dev-python/s3transfer/s3transfer-0.2.0.ebuild
deleted file mode 100644
index 633b1ff5ad76..000000000000
--- a/dev-python/s3transfer/s3transfer-0.2.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-inherit distutils-r1
-
-DESCRIPTION="An Amazon S3 Transfer Manager"
-HOMEPAGE="https://github.com/boto/s3transfer"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/botocore[${PYTHON_USEDEP}]
-"
-# Pin mock to 1.3.0 if testing failures due to mock occur.
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${CDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
-}