summaryrefslogtreecommitdiff
path: root/dev-python/scripttest/scripttest-1.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scripttest/scripttest-1.3.0-r1.ebuild')
-rw-r--r--dev-python/scripttest/scripttest-1.3.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/scripttest/scripttest-1.3.0-r1.ebuild b/dev-python/scripttest/scripttest-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..78cc074b2dfc
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.3.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="https://pypi.org/project/ScriptTest/
+ https://github.com/pypa/scripttest"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pypa/scripttest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+distutils_enable_tests pytest