summaryrefslogtreecommitdiff
path: root/dev-python/semver/semver-2.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/semver/semver-2.8.1.ebuild')
-rw-r--r--dev-python/semver/semver-2.8.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/semver/semver-2.8.1.ebuild b/dev-python/semver/semver-2.8.1.ebuild
new file mode 100644
index 000000000000..b7312e165270
--- /dev/null
+++ b/dev-python/semver/semver-2.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for semantic versioning"
+HOMEPAGE="https://github.com/k-bx/python-semver"
+SRC_URI="https://github.com/k-bx/python-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/python-${P}"
+
+python_test() {
+ pytest -v || die "Tests failed with ${EPYTHON}"
+}