summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-0.8.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.8.8.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.8.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.8.8.ebuild b/dev-python/snakeoil/snakeoil-0.8.8.ebuild
index c762561aef96..72c91229bc3c 100644
--- a/dev-python/snakeoil/snakeoil-0.8.8.ebuild
+++ b/dev-python/snakeoil/snakeoil-0.8.8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -27,6 +27,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
"
[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
python_test() {
esetup.py test
}