summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild')
-rw-r--r--dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild24
1 files changed, 8 insertions, 16 deletions
diff --git a/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild b/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
index 8e6f85629134..76e6ab45fc94 100644
--- a/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
+++ b/dev-python/sqlalchemy-rqlite/sqlalchemy-rqlite-9999.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -17,24 +19,14 @@ HOMEPAGE="https://github.com/rqlite/sqlalchemy-rqlite"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
dev-python/pyrqlite[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- )"
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
src_prepare() {
sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/sqlalchemy_rqlite/constants.py || die
distutils-r1_src_prepare
}
-
-python_test() {
- esetup.py test || die "tests failed"
- esetup.py lint -f text -E || die "pylint failed"
-}