summaryrefslogtreecommitdiff
path: root/dev-python/stestr/stestr-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stestr/stestr-4.1.0.ebuild')
-rw-r--r--dev-python/stestr/stestr-4.1.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/stestr/stestr-4.1.0.ebuild b/dev-python/stestr/stestr-4.1.0.ebuild
index ae45f1d2241a..7760baf20bc5 100644
--- a/dev-python/stestr/stestr-4.1.0.ebuild
+++ b/dev-python/stestr/stestr-4.1.0.ebuild
@@ -4,9 +4,9 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 pypi
+inherit distutils-r1 multiprocessing pypi
DESCRIPTION="A parallel Python test runner built around subunit"
HOMEPAGE="
@@ -39,6 +39,8 @@ BDEPEND="
"
python_test() {
+ local -x PYTHONPATH="${BUILD_DIR}/install$(python_get_sitedir)"
stestr init || die
- stestr run || die "Tests failed with ${EPYTHON}"
+ stestr run --concurrency "${EPYTEST_JOBS:-$(makeopts_jobs)}" ||
+ die "Tests failed with ${EPYTHON}"
}