summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest4
-rw-r--r--dev-python/trimesh/trimesh-4.4.0.ebuild6
-rw-r--r--dev-python/trimesh/trimesh-4.4.2.ebuild74
3 files changed, 80 insertions, 4 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index f526bead500f..93e3e5ef0717 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,3 +1,5 @@
DIST trimesh-4.4.0.gh.tar.gz 13599198 BLAKE2B 41fe6d8797bca600ef4526420b9a4bc3fe722adff3a6154625801b2e9a8645ad573f4f62926cd00763899d049660145d6e5614316fcfe3c4f4b76c59d59467ba SHA512 227f3da9e42bd2a872d312d5128d7ae169fcee8ef5566e533812fc6222fe6e5dc40c7802a5a7f1bbb583c700e6c8d1017ee1c6a946284e64679f3a138f31da6e
-EBUILD trimesh-4.4.0.ebuild 2032 BLAKE2B c2bb4eb32305d76b72862f868661df44344f4de1987ce65d5627df2b8a16c7b20bc11dbaf30ed66b27ba3826eb76f2bbc3455fc349c00ea46cb9112628f3f5e8 SHA512 beaf67d1d2290e1c538e489ee3f2e3fcd9786c7090bede09cbec3c5e08851fe3401bf6168304301062245d5e086b02c563caf73c9080de52d9ba5d1403602b9c
+DIST trimesh-4.4.2.gh.tar.gz 13607230 BLAKE2B fb1b904b873f1ace0956210ce01039a24dadeeb7d7316cae5c55286dead56d95a8fcb4a02b7193d0bf416c60ed1d5a0e3f475c63f45fcd75691f7ac9066ed845 SHA512 1b69fe5792236270c0351dba580edf3238a9f5235faa968078d52a085b818ef20772a360110b89d413bb916c07fb7db58db0c4d6ecbf8e69a436c2bae2d54fc8
+EBUILD trimesh-4.4.0.ebuild 2034 BLAKE2B 4a84fce060071ec2b8b2ab9abca89f200cff9050238c56cb7328fd482711c3b9f5986b14f76957385cb08b64fa7b724aaa634406009043e3898e0205d97cc1e0 SHA512 ee3c46c49128b3608c3fdf6eab1ded41ad937c07300e61ae78643bd336516f16e9e2cd0192b13d502b3f1442199b93cc3218b2284c61b0987cabdb19903fb4e5
+EBUILD trimesh-4.4.2.ebuild 2036 BLAKE2B fdc3533e944166ed99e70415f599e526e0a0eef5408ebea3e794a308ad5f2d98301a7984b9ad7570cdb939fcc528a3b01c9d6f8247cb195b54a4a4af338cefa3 SHA512 ff6e93c70c01ba4a711610db9e2a4ab818fdd4a78d9dbd35e410ac1fb3519a9358625fc0c5529eb95411a7329f56349c76b1ffe8c5f3c32ca1ca24add807fcbd
MISC metadata.xml 389 BLAKE2B 6dcc92dfafdedb5cc7fe5f40977594114bbf1628d8179d7222c3b60c4a591e236c7a937530006beb9649a8a84636bcb1923d8ad6a377994295f85b1fe8eb8bbd SHA512 a96f4fb6a1c2bd820f2dd072230fa160536834e1ef19483c372571df2d082cb5a63434181af9107022b75e1019d369d6bece8262eb752cedf24a5038e15ea473
diff --git a/dev-python/trimesh/trimesh-4.4.0.ebuild b/dev-python/trimesh/trimesh-4.4.0.ebuild
index 2ba9f811f9ea..b9898a47ae41 100644
--- a/dev-python/trimesh/trimesh-4.4.0.ebuild
+++ b/dev-python/trimesh/trimesh-4.4.0.ebuild
@@ -41,11 +41,11 @@ RDEPEND="
dev-python/svg-path[${PYTHON_USEDEP}]
dev-python/sympy[${PYTHON_USEDEP}]
dev-python/xxhash[${PYTHON_USEDEP}]
- sci-libs/rtree[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
- dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
dev-python/pillow[webp,${PYTHON_USEDEP}]
)
"
@@ -67,7 +67,7 @@ python_test() {
pkg_postinst() {
optfeature_header "${PN} functionality can be extended by installing the following packages:"
optfeature "making GUI applications with 3D stuff" dev-python/glooey
- optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
optfeature "loading a number of additional mesh formats" dev-python/meshio
optfeature "figuring out how much memory we have" dev-python/psutil
optfeature "marching cubes and other nice stuff" dev-python/scikit-image
diff --git a/dev-python/trimesh/trimesh-4.4.2.ebuild b/dev-python/trimesh/trimesh-4.4.2.ebuild
new file mode 100644
index 000000000000..37fd5b19ad93
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}